Back to overview
Degraded

Developer Portal Errors

Mar 07 at 05:30pm UTC
Affected services
API Developer Portals

Resolved
Mar 07 at 08:00pm UTC

We have identified the root cause of the issue. The issue occurred when a user authenticated to the developer portal and the server session state was not present. This could occur both for authentication sessions that were left open for more than 8 hours (the session cookie was set for a longer expiration time than the session storage) or in the event that a new session had not yet replicated to additional storage locations and was requested quickly.

We have corrected the issue and added additional testing and monitoring to ensure this type of error is caught more quickly in the future.

Updated
Mar 07 at 07:32pm UTC

We have identified one of the issues as not being an issue with Zuplo's dev portal, but rather isolated to a single customer's configuration.

We are continue to investigate the invalid session issues.

Created
Mar 07 at 05:30pm UTC

We are seeing an elevated error rate on hosted API Developer Portals (i.e. the /docs) sites. The errors returned result in 404s or internal server errors.

The team is actively working on a fix.